Tutorial

  • Download image for Raspberry Pi 3, for example Pi 3 model B
  • Write the image to USB (or SD card)
  • If booting from USB has been set, open cmdline.txt on the USB and change root to /dev/sda2 instead of mmcblk2, which is pointing to SDcard partition.
  • That’s it. Plug the USB to the board and boot.

Access OpenWrt and configure

  • Plug Ethernet port on desktop directly to that on Raspberry Pi

  • Use ssh to access OpenWrt on 192.168.1.1

  • Install HTTP access

opkg update
opkg install luci

Then open web browser and access the router at 192.168.1.1

We can now configure the router using HTTP interface. However, it is also possible to configure the router as follow in advance and modify it later using HTTP interface.

  • Enable wifi
# uci set [email protected][0].disabled=0; uci commit wireless; wifi
  • then edit the configuration file to enable Internet access and define wifi network
# vim /etc/config/network

replace its content as follow

config interface 'loopback'
  option ifname 'lo'
  option proto 'static'
  option ipaddr '127.0.0.1'
  option netmask '255.0.0.0'

config globals 'globals'
  option ula_prefix 'fd8a:0abc:79d8::/48'

config interface 'lan'
  option _orig_ifname 'wlan0'
  option _orig_bridge 'false'
  option proto 'static'
  option ipaddr '192.168.1.3'
  option netmask '255.255.255.0'
  option ip6assign '60'

config interface 'wan'
  option proto 'dhcp'
  option ifname 'eth0'

config wifi-device 'radio0'
  option type 'mac80211'
  option channel '11'
  option hwmode '11g'
  option path 'platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
  option htmode 'HT20'
  option country '00'

config wifi-iface 'default_radio0'
  option device 'radio0'
  option network 'lan'
  option mode 'ap'
  option ssid 'RPi3'
  option encryption 'psk2'
  option key '12345678'

Save the file, exit and reboot.

  • Now it is possible to connect to the wireless network named LEDE, the default gateway address of this router is now 192.168.1.3 as in the configuration file above.

  • Internet access can be enabled by plugging the Ethernet port on Raspberry Pi 3 to the Internet router. This way, the home network can see OpenWrt router as a bridge to a separate network.

References

  1. OpenWrt Downloads
  2. How to install OpenWrt on Rasp Pi 3
  3. Luci HTTP interface